Introduction
Once you create your vendors' inventory feeds and fetch them, their products will be imported into Onport. After that, you'll need to publish the items to your online store so they become available to sell. However, a few things can happen from this point on. In this article, we'll explain the best method to resolve the situation when an item goes back to the "not published" status after you published it.
The process
Initially, the products will have the status "not published" and "not connected to your online store":
After clicking the "Publish" button, you'll see a different status - "Publishing". Here, two things can happen:
1) The product is now "published" and "connected" - you'll be able to see the product in the main inventory section in Onport and in your e-commerce platform. The publishing process was successful!
2) The product goes back to "not published" - Onport should display the description of the error if you click the product name. You'll find details explaining why it failed under "Publishing problem":
Potential causes
It can be because you have products with the same name or with the same SKU in your store or in another vendor's inventory feed. Or there could have been a connection issue at the time of publishing and we may not have logs to show exactly what happened.
- If the product is already being sold by a different vendor, you can connect the 2 items using the "connect" button - see this article for more information.
- You can also prefix the brand's SKUs to avoid this:
How to fix
In order to fix this, we recommend deleting the variants from your store if they made it there, deleting them from the main inventory section in Onport and then republishing the variants from the vendor's inventory feed.
If the issue still persists, please open a ticket with us and send us an example SKU that the team is authorized to republish for you and troubleshoot the issue.
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